Live Web Streams

Technical Assistance

If you are having technical difficulties with the livestream, check the information below as it offers solutions for common problems that people encounter during web streaming.

Lost or No Sound

  1. Check your sound setting on your computer Make sure it is on, the mute button is not check and the volume is toward the middle or high end of the range.
  2. Check your system preferences on your hard drive (within Applications on a Mac, on the C:/ drive on a PC). Make sure the sound setting is properly selected.
  3. If you have external speakers, check to be sure they are plugged in, turned on and the volume is toward the middle or high end of the range.
  4. Check the sound setting on the video player screen. Ensure that the mute button is not checked and that the volume is at the middle or high end of the range.
  5. If you have followed all of the above suggestions and still are hearing no sound, try refreshing the page. You may need to click the play button again on the video player to restart the web stream.

Lost or No Video/Picture

  1. If you are seeing the blank UStream video screen on the page and it has a right-pointing arrow in the middle, click the arrow to start the web stream.
  2. If you lose video or it seems slow during the stream, try refreshing your browser.
  3. If you have tried refreshing your browser and that hasn’t helped, try clearing your cache/history. To clear the cache (short-term memory), go to “Preferences” within the browser you are using—it may be found under the word “File” or the name of the browser (Firefox, Safari, Chrome, Internet Explorer, etc.). Click on the drop-down menu and select “Clear History” or “Clear Cache.” Once you have completed all of the required steps to clear your cache, refresh the livestream page again and, if necessary, restart the web stream.